file Nečitateľné čísla v Ubuntu 13.04

  • ainur
  • ainur-ov Avatar
  • Online
  • Prémiový člen
  • Prémiový člen
  • Ubuntu 14.04
Viac
21 sep 2013 11:03 #9194 od ainur
Ubuntu 13.04 má problém, keď máte ako jazyk prostredia nastavenú slovenčinu. V programoch sa vám vo formulároch namiesto čísel zobrazujú všelijaké kliky-haky. Po niekoľkých mesiacoch ma to už dokúrilo a našiel som riešenie. Stačí pridať tento riadok do súboru ~/.profile + odhlásiť a prihlásiť sa:
export LC_NUMERIC=en_DK.UTF-8

Dúfam, že to niekomu pomôže. Riešenie je z tejto stránky: askubuntu.com/questions/310990/borked-en...-for-slovak-language

Prosím Prihlásiť alebo Registrácia pre zdieľanie konverzácie.

Viac
21 sep 2013 17:36 #9195 od jansuv
Odpoveď od jansuv na tému Re: Nečitateľné čísla v Ubuntu 13.04
A kde to vložiť v linux mint 15 KDE? .profile tam nikde nie je.

Prosím Prihlásiť alebo Registrácia pre zdieľanie konverzácie.

  • ainur
  • ainur-ov Avatar
  • Online
  • Prémiový člen
  • Prémiový člen
  • Ubuntu 14.04
Viac
21 sep 2013 17:53 #9196 od ainur
Odpoveď od ainur na tému Re: Nečitateľné čísla v Ubuntu 13.04
Nuž, to je dobrá otázka. :D Ak mám pravdu povedať, tak neviem. V prvom rade sa ešte raz pozri či ten súbor v domovskom adresári predsa nie je. Súbor sa začína bodkou, čiže je skrytý. Pre jeho zobrazenie musíš v správcovi súborov stlačiť CTRL+H, teda ak používaš Nautilus/Nemo. Dúfam, že som ťa touto poznámkou o skrytých súboroch neurazil. 8) A keď to nenájdeš tak skús vytvoriť tento súbor ty sám. Potom napíš, či to fungovalo.

Prosím Prihlásiť alebo Registrácia pre zdieľanie konverzácie.

Viac
21 sep 2013 18:22 #9197 od jansuv
Odpoveď od jansuv na tému Re: Nečitateľné čísla v Ubuntu 13.04
ďakujem za info. O skrytých súboroch som vedel, ale zle som hľadal v priečinkoch s bodkou a ono to bolo nižšie ako txt.
Uvedený text som vložil, ale asi zle, lebo to nepomohlo. Text súboru profile je uvedený nižšie. Za každú radu som vďačný a Tebe Ainur ďakujem.

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
# include .bashrc if it exists
if [ -f "$HOME/.bashrc" ]; then
. "$HOME/.bashrc"
fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
PATH="$HOME/bin:$PATH"
fi
export LC_NUMERIC=en_DK.UTF-8

Prosím Prihlásiť alebo Registrácia pre zdieľanie konverzácie.

  • ainur
  • ainur-ov Avatar
  • Online
  • Prémiový člen
  • Prémiový člen
  • Ubuntu 14.04
Viac
21 sep 2013 18:44 #9198 od ainur
Odpoveď od ainur na tému Re: Nečitateľné čísla v Ubuntu 13.04
Nuž podľa komentára, ktorý je v súbore, by som najskôr skontroloval, či nemám v domovskom priečinku vytvorené súbory ~/.bash_profile alebo ~/.bash_login. Ak áno, tak tam nakopíruj ten riadok. Keď nie, tak spusti v Termináli tento príkaz:
locale -a
a skontroluj či ti to vypíše aj en_DK.UTF-8. Ak nie, vyber si iný riadok končiaci na utf8 (napríklad en_US.utf8) a ten obdobne vlož do súboru ~/.profile. Nezabudni reštartovať počítač.

Prosím Prihlásiť alebo Registrácia pre zdieľanie konverzácie.

  • janek-m
  • janek-m-ov Avatar
  • Online
  • Junior člen
  • Junior člen
  • Kubuntu 12.04 LTS
Viac
22 sep 2013 07:51 - 23 sep 2013 11:35 #9199 od janek-m
Odpoveď od janek-m na tému Re: Nečitateľné čísla v Ubuntu 13.04
zmazané
Posledný krát upravené:23 sep 2013 11:35 janek-m

Prosím Prihlásiť alebo Registrácia pre zdieľanie konverzácie.

Čas vytvorenia stránky: 0.079 sekúnd